Welcome aboard Ultimate Edition 3.4 LTS

by on Jul.01, 2012, under Linux, Themes, Ubuntu, Ultimate Edition

I am proud to announce the release of Ultimate Edition 3.4 a long term supported release.  I have also re-opened donations, please show your support.

I have began comunication with sourceforge to understand how many hours I need to provide in advancement, you can at this time obtain x64 of UE 3.4. 8 hrs was not enough for 32 bit, we are movin vast volumes of information across the world. Please sit tight until Monday. Next time I will come like a thief in the night 😉



21 Comments for this entry

  • Steven

    Thank you thank you thank you Thee Mahn…try in to make A donation soon…almost able to…at least something for all I have from UE.Thank you … 🙂

    • TheeMahn

      Thanks, donations have been rollin in quite well for only being a few hours $175. My acct is still in the negitive, I am sure that will soon change. If not when I snatch my check this week will drop it in paypal. Was $270 in the hole when I opened it back up. A long story, my acct has been down since 2008. I used to sell 2,500 products online. A lady I use the term lightly bought $270 worh of goods from me and claimed she did not recieve them even though I provided paypal with tracking information they sided with her even though I had sold over $60,000 worh of goods that year & not a problem 1. I refused to let her have the products and her money back paypal restricted my acct & I shut down the website. Sometimes people can be so shiesty.

      The end of the situation, I loaded a card with $300 and paid it off she got her money back anyway. Well at least it is back up. You have no idea, how stomach turning it was to send that money back to her.

  • Steven

    wow..yes the robbers are out there. Its difficult to get paid these days since i am just starting to sell some art for my boss on Ebay..its not the same..i used to be able to get checks..not anymore..it all goes trhough PayPal..and they are holding some of my money…sheeeeeeeeeeeeeesh… ㋛

  • norox

    Sorry to hear about paypal so many things I could call them, I sell documentaries on DVD and not for profit only a small amount goes towards my time and living anyhow, paypal restricted my account to the extent they claimed I was not for profit and asked me to provide documentation, passport bank statements for last 4 months, proof of account ownership I also had to provide proof of organization / charity but all got sorted out but I hardly use paypal as lost trust in them… sorry for off subject — will make donations though, thanks

  • Carling

    I downloaded 3.4 32 and 64 bit, within seconds of it being release, I installed the 64 within the hour, Everything works out of the box.. You have hit the jack pot with this one, what a brilliant job, thank you

  • TheeMahn

    Thanks Carling, I really enjoy it too.

  • kruger1973

    Muchas gracias por el trabajo realizado. 😉

  • jimdoc

    I downloaded 3.4 32 bit and burned the disc. When I choose try it locks up, anybody else have this problem. I have not tried installing yet since the try option isn’t working right. Should I try downloading again to try another disc?

    I have never had a problem with any other release and was really looking forward to this LTS.


    • TheeMahn

      Jim, please break down your hadware, I suggest on the forum, however I will attemt to resolve your issues. What I am asking what computer do you have as well as wifi etc. I am happy to meet a failure knowing what I know. Let’s get it out in the open.

  • jimdoc

    I am using an older MPC P-4 Duo core 3 GHz still running Ubuntu 10.04 with Verizon DSL and no wifi .
    When it downloaded it was 2.9 gb and not the 3.1 gb I thought it should be. When it gets to the Try or Install section I choose Try and then it locks up with the UE logo in the center of the screen.
    Just wondering if it was a bad download because of the 2.9 gb total? Maybe it’s because of the slow DSL?
    I tried downloading UE 3.3 and it kept stopping way short of the total gb it should have been.
    I have a few other computers to try it on, and will do that today
    Thanks. Jim

  • jimdoc

    I just joined the forum and moved the question over there, sorry for not doing that in the beginning.

    Thanks. Jim

  • ibmorjamn

    Glad your back up. I was running around trying to find out what happened, nothing on Ubuntu, some crazy stuff on the aussie site. I will try to get you a donation. It might be after August though.
    I have to say I have been running 3.0 for a while. I like it. I hope I can install 3.4 and just keep my home info. I know thats what I used to do for PClinuxos.

  • rockinkaj

    Thanks TheeMahn 3.4 x64 is BEAUTIFUL PERFECT!!!!

  • weaselnet

    The installer keeps crashing on me while retrieving files. Installing on a VGN-FZ290. Try seems to run fine. Installing off a USB drive.

    • weaselnet

      Creating user

      ultimate pluginstall.py: Install Step Error: Plugin usersetup failed with code 32
      ultimate pluginstall.py:
      Home directory /home/ultimate not ours.

  • distrodad

    Thee- WOW,WOW,WOW!!! I was all set to run 2.6 to end of
    support and leave Ubuntu behind after that. What you have done on 3.4 is totally above and beyond. I can not thank you
    enough for what you have done for the Linux Community.
    I also hope you have much success in all you do.Thanks for
    keeping it going in such style and purpose.

  • jimcarter1959

    I just discovered this incredible product recently! It appears to be flawless and have unlimited uses!

    My only wish is that version 3.4 worked with the USB tool called YUMI. I have to use version 3.0 with YUMI. In order to get Ultimate Edition on a USB stick I had to go with Unetbootin.

  • justinstrack

    I couldn’t use 3.2 because I could never get it to install. I used 3.3. 3.4 installed so fast.

1 Trackback or Pingback for this entry

Leave a Reply

You must be logged in to post a comment.

Back to top ↑